[RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

General forum for Buanzo's Enigform and mod_openpgp (HTTP+OpenPGP). Check out the subforums, too!

[RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor buanzo el Lun Jun 18, 2007 9:30 pm

Although this release does not take into account the security concerns of user dinkel, it is a step towards a more solid OpenPGP extension for HTTP, as it introduces the "Discovery" method: Enigform can now tell if the remote site supports (and has enabled) the OpenPGPEngine through mod_auth_openpgp (no other implementations available, yet).

Check out:

http://linux-consulting.buanzo.com.ar/2 ... eased.html
http://linux-consulting.buanzo.com.ar/2 ... eased.html

Sincerely,
Buanzo
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

[RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Sponsor

Sponsor
 

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor lace el Mar Jun 19, 2007 9:42 am

buanzo escribió:"Discovery" method: Enigform can now tell if the remote site supports (and has enabled) the OpenPGPEngine through mod_auth_openpgp

Great, just testing. Seems it works.
Problem is with signed request from enigform. It works but when click to enigformtest (signed request) it causes mod_auth_openpgp segfault.
Tested with both Windows and Linux version of enigform.
lace
 
Posts: 12
Registrado: Lun May 14, 2007 7:00 pm

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor buanzo el Mar Jun 19, 2007 9:55 am

It the gpg setup is complete for the user for Apache (or that particular virtual host if you're using mod_itk), then it should not segfault. Try suing to the apache (or equivalent) user, and run "gpg".
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor buanzo el Mar Jun 19, 2007 10:34 am

I just upgraded enigformtest.buanzo.com.ar's Apache with mod_auth_openpgp 0.2.1.

If you visit http://enigformtest.buanzo.com.ar/ with an Enigform 0.8.1-enabled browser, you'll notice that instead of "OpenPGP: NO", the status bar will say: "OpenPGP: yes (mod_auth_openpgp/0.2.1)".

Smile
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor lace el Mar Jun 19, 2007 11:09 am

buanzo escribió:"OpenPGP: NO", the status bar will say: "OpenPGP: yes (mod_auth_openpgp/0.2.1)".

Yea, your server works like a charm. I can see this status bar on my server only if enigform does't sign request. With signed request m_o_a segfaults.

GPG setting should be OK, because my enigformtest works if "#OpenPGPEngine on".
With "OpenPGPEngine on" I can see status bar with yes but only if enigform doesn't sign request.

It would be fine if m_o_a writes some log messages.
lace
 
Posts: 12
Registrado: Lun May 14, 2007 7:00 pm

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor lace el Mar Jun 19, 2007 12:01 pm


After installing this version seems in Firefox in MS Windows the combination ctrl-t ctrl-v (open new tab and paste url) doesn't work.
Firefox without this version enigform or with version 0.8 seems work.
lace
 
Posts: 12
Registrado: Lun May 14, 2007 7:00 pm

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor lace el Mar Jun 19, 2007 12:39 pm

Firefox in MS Windows the combination ctrl-t ctrl-v (open new tab and paste url) doesn't work.

The same problem in Linux.
lace
 
Posts: 12
Registrado: Lun May 14, 2007 7:00 pm

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor buanzo el Mar Jun 19, 2007 5:05 pm

Yep, I noticed it. I believe it has to do with the fact that I update the statusbar in the middle of an event that gets fired during tab-change. I might just need to force focus on the addressbar. Any ideas?

Additionally, I've been working all day on implementing enigform and mod_auth_openpgp "import key" functionality. I'm having some issues with gpgme import operation. Any gpgme expert here? Smile

Also, I tried removing ~apache/.gnupg, and to make it work I had to:

Código: Seleccionar todo
su - apache
gpg -K
gpg --gen-keys
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor dinkel el Mar Jun 19, 2007 5:58 pm

Enigform installs without any problems and it works as expected on your testpage. Nice one!

buanzo escribió:Yep, I noticed it. I believe it has to do with the fact that I update the statusbar in the middle of an event that gets fired during tab-change. I might just need to force focus on the addressbar. Any ideas?


I started to have a look at it ... possibly I will send a patch quite shortly if you like?! used to hack on a firefox plugin and it's quite a good opportunity to refresh my knowledge. I also figured out that if you are looking at local files then in the status bar 'Testing...' will stay forever. 'OpenPGP: NO' would be correct. Again if I find something, you'll get a patch.

And after that, I have to set up an Apache server to also test mod_auth_openpgp ;-)
dinkel
 
Posts: 4
Registrado: Vie Jun 15, 2007 8:06 am

Re: [RELEASE] Enigform 0.8.1 and mod_auth_openpgp 0.2.1

Notapor buanzo el Mar Jun 19, 2007 6:00 pm

I've fixed the "no focus on new-tab" bug described above.

Regarding "Testing..." when schema is not http, or https, I'll have it done right away.
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

Siguiente

Volver a Enigform and mod_openpgp

¿Quién está conectado...?

Usuarios navegando este Foro: Google [Bot] y 1 invitado

cron