problemas con el sonido al grabar

Todo acerca del sistema operativo mas feliz que existe.

problemas con el sonido al grabar

Notapor Sisifo el Sab May 12, 2007 12:57 am

Tengo una placa de tv y me costo mucho hacerla funcionar pero el problema es que cuando trato de grabar con mencoder la imagen es buena pero es sonido hace un zumbido bastante molesto , lo mismo me ocurre cuando trato de grabar con audacity
pd:Buanzo muy buena la info para escuchar radio por internet
"Aces are larger than life and greater than mountains" Mike Caro
Avatarde Usuario
Sisifo
 
Posts: 9
Registrado: Sab May 12, 2007 12:49 am

problemas con el sonido al grabar

Sponsor

Sponsor
 

Re: problemas con el sonido al grabar

Notapor buanzo el Sab May 12, 2007 11:08 am

Tengo un scriptcito que permite grabar webcam con audio....

si te interesa lo busco y te lo paso.

el tema del zumbido: probaste grabando audio con cualquier otra aplicacion? asi al menos podemos saber si es un drama tuyo con mencoder, o si es general... lo mas probable es que sea ruido o estatica....

por que no nos pasas un .wav/.ogg asi podemos escuchar el ruido? yo puedo decirte de donde viene el problema escuchandolo.
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

Re: problemas con el sonido al grabar

Notapor Sisifo el Lun May 14, 2007 3:43 am

grabando un video con mencoder o grabando sonidos con audacity , que es un programa para grabar y editar sonidos , hace el mismo zumbido , aca te paso unos archivos para que los escuches
http://w13.easy-share.com/1086973.html

con solo escucharlo sabes de donde viene el problema ?????
EL QUE SABE , SABE Smile

este es el script que uso para grabar (funciona pero el problema es el zumbido)
--------------------------------------------------------
#!/bin/bash
#
# script to encode tv using mencoder
#
# usage tape <channel#> <name> <duration>
#
CHAN="$1"
FNAME="$2"
DURATION="$3"

if [ $# -ne 3 ]
then
echo "Usage tape <Channel> <Name> <duration>"
echo "duration = hh:mm:ss"
exit
fi

echo
echo "Taping " "$FNAME""_`date +%m%d`"
echo

mencoder tv:// -tv driver=v4l:input=0:norm=palnc:chanlist=us-cable:channel=$CHAN:width=640:height=480 -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=3000 -ofps 25 -oac mp3lame -lavcopts acodec=mp2:abitrate=128 -srate 44100 -vf scale=640:480,pp=hb/vb/dr/al/lb -endpos $DURATION -o "$FNAME"_`date +%m%d`.avi -quiet
---------------------------------------------------
"Aces are larger than life and greater than mountains" Mike Caro
Avatarde Usuario
Sisifo
 
Posts: 9
Registrado: Sab May 12, 2007 12:49 am

Re: problemas con el sonido al grabar

Notapor buanzo el Lun May 14, 2007 10:36 am

Te paso el script que uso yo para capturar webcam + audio desde line/mic:

Código: Seleccionar todo
mencoder tv:// -tv forceaudio:alsa:driver=v4l:device=/dev/video0:width=640:height=480:fps=12:brightness=90:volume=35000 -o $1 -ovc lavc -lavcopts vcodec=mjpeg -oac mp3lame


De escuchar el audio, me tiro a interferencia, y probablemente de la propia capturadora. Te recomendaria que juegues con los parametros de los modulos un cacho mas. Yo capturaba el audio con un cablecito chiquito que salia de la tv y entraba a la placa de sonido por line. tomaba el audio por alsa y el video por v4l. fijate que onda...

Si es otra interferencia... agarra el alsamixer, y con la tecla "m" vas muteando varios canales (con arriba y abajo prendes y apagas ciertos seteos). Hay uno que a mi me daba un ruido del carajo, era: IEC958. Move de lugar la placa, abri tu cpu y chusmea'.
Avatarde Usuario
buanzo
Administrador
 
Posts: 673
Registrado: Sab Dic 09, 2006 11:17 am
Ubicación: Buanzonia (ok, Florida, Buenos Aires)

Re: problemas con el sonido al grabar

Notapor Drogoman el Mar Mar 25, 2008 3:30 pm

hola a todos, yo tambien tengo (tuve)el problema delchillido al grabar con mencoder, leyendo lo que ambos escribieron, coloque la opcion forceaudio:alsa y voila adios ruido, solucionado, al menos para mi, a ver si prueban y me dicen que tal les fue.

slds
Drogoman
 
Posts: 1
Registrado: Mar Mar 25, 2008 3:27 pm


Volver a GNU/Linux

¿Quién está conectado...?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 1 invitado

cron